Kolejny błąd napotkany przeze mnie podczas upgrade’u aplikacji ASP.NET Core z wersji 2.2 do wersji 3.1 to błąd: „CS1061 ‚IApplicationBuilder’ does not contain a definition for ‚UseDatabaseErrorPage’ and no accessible extension method ‚UseDatabaseErrorPage’ accepting a first argument of type ‚IApplicationBuilder’ could be found (are you missing a using directive or an assembly reference?).

Widok błędu

Aby naprawić ten błąd, z Nugeta doinstalowałam do projektu bibliotekę „Microsoft.AspNetCore.Diagnostics.EntityFrameworkCore” w wersji 3.1.3. Po doinstalowaniu tej biblioteki, problematyczny błąd znika z projektu.

Dodanie biblioteki z Nuget'a

Błąd zostal naprawiony:

Widok aplikacji

 

 

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *